IE Update Corrects Code Execution and Information Disclosure Flaws

Severity: High

12 April, 2011

Summary:

  • This vulnerability affects: All current versions of Internet Explorer, running on all current versions of Windows
  • How an attacker exploits it: Typically, by enticing one of your users to visit a malicious web page
  • Impact: In the worst case an attacker can execute code on your user’s computer, gaining complete control of it
  • What to do: Deploy the appropriate Internet Explorer patches immediately, or let Windows Automatic Update do it for you

Exposure:

In a security bulletin released today as part of Patch Day, Microsoft describes five new vulnerabilities in Internet Explorer (IE) 8.0 and earlier versions, running on all current versions of Windows. Researchers reported four of the new vulnerabilities privately to Microsoft, while the other one was disclosed publicly. They rate the aggregate severity of these new flaws as Critical.

The five vulnerabilities differ technically, but three of the worst flaws share the same general scope and impact. This trio of flaws all involve memory corruption issues having to do with how IE handles various HTML elements, including MSHTML objects and page layouts. If an attacker can lure one of your users to a web page containing malicious web code, he could exploit any one of these three vulnerabilities to execute code on that user’s computer, inheriting that user’s privileges. Typically, Windows users have local administrative privileges, in which case the attacker gains complete control of the victim’s computer. Attackers often leverage these type of code execution vulnerabilities to launch Drive-by Download attacks.

The remaining two issues are less severeĀ  information disclosure and click-jacking vulnerabilities.

Keep in mind, today’s attackers commonly hijack legitimate web pages and booby-trap them with malicious code. Typically, they do this via hosted web ads or through SQL injection and XSS attacks. Even recognizable and authentic websites could pose a risk to your users if hijacked in this way.

If you’d like to know more about the technical differences between these flaws, see the “Vulnerability Information” section of Microsoft’s bulletin. Technical differences aside, the memory corruption flaws in IE pose significant risk. You should download and install the IE cumulative patch immediately.

Solution Path:

These patches fix serious issues. You should download, test, and deploy the appropriate IE patches immediately, or let Windows Automatic Update do it for you.

Internet Explorer 6.0

Internet Explorer 7.0

Internet Explorer 8.0

* Note: These flaws do not affect Windows Server 2008 administrators who installed using the Server Core installation option.

For AllĀ Users:

These type of attacks typically look like normal-looking HTTP traffic, which you must allow if your network users need to access the World Wide Web. Therefore, the patches above are your best solution.

Status:

Microsoft has released patches to fix these vulnerabilities.

References:

This alert was researched and written by Corey Nachreiner, CISSP.

This entry was posted in Uncategorized and tagged , , . Bookmark the permalink.

Leave a Reply